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STEP ONE: Creating the game layout

1Open Flash and create a new document window.

Select Modify>Movie to bring up the basic settings

for the game layout. Select the background colour and

frames per second (fps) of the game.You will also need

to choose the dimensions of the game-playing area.

3Using the small plus symbol at the base of the

timeline, insert a new layer above the background

layer.You can now add text and graphics to this layer

including the name of the game and the instructions on

how to play.

4 In this game there are going to be several levels, so

we need to create a password system and enable

the player to enter the passwords for the later levels.

When you create the text for the level 1 password you

need to ensure that the text options are set to Input Text

and provide this text with the variable “password”.

5 The game will include a number of different buttons

which will all have the same style. Create a new

symbol by selecting Insert>New Symbol and create the

background for use in your buttons. Flash comes with a

selection of ready-made buttons and graphics which you

could use.

6 Create another symbol and set the behaviour to

“button”. Use the instance of the button underlay

you have just created as the backdrop for the button.You

can create the Up and Over states using different

graphics or, as we have done, different coloured text for

the different button states.

7As this is the introduction page to the game this will

be the screen players will come back to to restart

and enter passwords for different levels.To ensure that

they come back to the right scene and frame you will

need to label the frame. In the frame panel simply label

the frame as “intro”.

8Macromedia’s Exchange for Flash is a repository for a

wide range of ready-made fancy scripts and actions

which can animate and improve the presentation of your

work.We have added a particle effect and changed the

graphic to the title of our game.This then animates

behind the instructions.

9Now you have finished the introduction screen you

need to create the background graphics for the

main game screen. First select Insert>Scene and then

return to your Intro scene to copy the frame that made

up the background layer using Edit>Copy frames – now

paste these into your in-game scene so you can start

creating the components for the game.
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2 You can now create the background for the game.

We are using two white bands to separate the game

playing area and the functional areas which will hold

details such as the score.You should also label the layers

– just click on the name to edit them as this helps you to

manage the layers that will build up in your game.

MF108.tut_flash  16/8/01  2:58 pm  Page 122



123October 2001  

TRANSPARENT FILL
You can create a gradient fill which is transparent so that the
layers underneath can be seen through. To adjust the colour use
the mixer rather than the Swatches palette, as this enables you to
adjust the Alpha channel for that colour. You can add this semi-
transparent colour to the swatches. Then open the Fill palette and
select the radial gradient, and the transparency colour will be
included in the fill type or can be chosen from the swatch palette.

NO LOOPS PLEASE
Flash movies have a tendency to loop, particularly when you
create a small animation in a Symbol. Stop this by adding an
ActionScript to the last frame you want played. Then add the Stop
command to the frame. If your movie is simply an introduction to
something, when you export the movie ensure that you set the
HTML publish settings to prevent looping, which is done by
unchecking the appropriate box in the settings window.

USE SYMBOLS
By converting your imported graphics into symbols you can apply
effects to them in the same way that you can apply effects to
vector shapes. This enables you to adjust elements of the image
such as tint, brightness and transparency. In turn these elements
can be tweened between two or more keyframes, enabling you to
animate the instances of the effects that you have applied to the
bitmap image.

TIPS
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STEP TWO: Coding

1 Create a graphic that you want to use and make an

identical copy of the image, now make five

alterations to the copy and save them both as PICT files.

Using the import function in the Flash file menu you can

import these graphics and position them onto a new

layer next to each other.

2As we want to deduct points if the player selects the

wrong area, you need to create a new symbol which

acts as a button.This button is a big invisible square the

same size as the images which we will lay over the top of

the graphic, but keep them on separate layers.

3 To provide the player with feedback when they hit

the right area, you need to create a response. Create

a symbol with an animation and possibly a sound effect.

We have created a small sphere that glows and then

added a script to stop the animation at the end of the

animation frames.

4 These targets that you have created can now be

dragged to the areas of the images that you have

altered. Put the targets onto a new layer.You can hide

some of the other layers if they get in the way when

aligning your target circle symbols with your image.

5 To give players a chance of hitting the targets with a

mouse click, create a new symbol of a button. Add

the targets to the areas that you want the players to click

on to create a hit. Leave a reasonable overlap.

6Now we need to start scripting.The game will have

a score and a number of options to help you out, so

back in the Intro scene set up the values for these

variables. As the player’s score should start with zero, set

it to this value and set the Help value to somewhere

between 2 and 5 clues.

7 The basic game script is fairly simple.You create a

loop to set the values of the targets to zero.The

invisible buttons with variable names “re1” to “re5” can be

pressed once, which changes their values to 1 and

prevents them from being pressed again.

8Now for each of the small invisible targets you need

to add the actions.The script tells the Target to play

the response animation and add ten points to the score

value, which we set at zero in step six.

9 The score can be displayed as Dynamic text using

the variable “score”.The game will use a time limit so

we create another Dynamic text box to display the

variable “time”. As the movie plays at 12 frames per

second, 12 seconds of animation lasts a second so you

need to create an empty movie symbol which lasts 12

frames to represent 1 second.

➔

➔

Pete Barr-Watson
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OPEN EMAIL
To create a button in Flash that will open your email package,
enter the address and subject and body copy if desired. Create a
button and add to it the Action On (Release) then add Get URL
(“”) and End On. In between the quotes add the normal HTML-
style information: mailto:macformat@futurenet.co.uk?subject=
Comments on Flash tutorial&body=My comments

THINK SMALL
Optimising your Flash content is essential and there are several
ways to reduce the size of the exported SWF file. Use tweened
animations rather than frame-by-frame style animations. Using
the Symbol Library to store elements that will be used more than
once will reduce the amount of data needing to be compressed,
so is the best way of reducing file size without reducing quality.

SYNCHRONISE SOUND
This is easiest if the sound is set to play when a specific frame in
the animation is reached. If the audio is spoken, it may be
necessary to break the audio files into sentences and synchronise
each one to the animation. Use the stream synchronisation for
audio found in the sound panel which will, if necessary, drop
frames to ensure it stays in time with the audio track.

TIPS

10Now create an additional frame at the start

with an ActionScript for the variable for the

time to equal 20. On the last frame create another

ActionScript which counts down in increments of 1 each

time the 12 frames play. If the time reaches zero the

game stops, otherwise it plays the 12 frames again.

11Although the time will display in the dynamic

text box you can also create a visual time bar

which is simply an animation of a bar that shrinks over

240 frames – the equivalent of 20 seconds.The timer 

bar is contracted between two keyframes using 

motion tweening.

12Add the variable password into the ActionScript

for the first frame of the level and then return

to the intro scene to add an ActionScript to the start

button.The ActionScript works on the release of the

button, or upon pressing Enter after typing in the

password for the level.

13 To make the game easier we are going to add a

help system, so create a dynamic text block to

display the value of “help” which we set to 5 earlier. Also

create a new symbol for the Help button in the same way

as you did to create the Start button.

14 The ActionScript for the Help simply checks

whether the target values have been pressed in

turn. Each target has to be checked and played if it has

not already been pressed. If the last clue in the scene is

revealed then the script is used to take the player to the

next scene.

15Using the same principles throughout this

stage of the tutorial you can repeat these steps

to create more levels.We have labelled these scenes 1, 2,

3 and 4 and have amended the code in each level to add

the password into the first frame.

16 Create a new scene for the end of the game.

This end-of-game screen displays two variables

using the dynamic text – the score and the password

variable from the last level you played.We have also

added a button that takes you back to the Intro scene so

you can play again.

17ActionScripts can become very complex and so

it is essential to use the Syntax testing tool

within the Object Actions scripting window. If you find

errors the Help menu has both the ActionScript

Reference and the ActionScript Dictionary to help you 

fix any problems.

18 Your game is just about finished, so test the

code using the Test Movie function under the

Control menu.This in turn shows you the size of the

movie and enables you to check the variables are

producing the right values while playing the game.

MF108.tut_flash  16/8/01  2:58 pm  Page 124



KEEP FILES SMALL
If your document contains a lot of text your files may be very
large. Breaking text up  increases the overall file size so keep this
to a minimum. Don’t use too many fonts. Take advantage of the
three device fonts which are called _sans, _serif and _typewriter
– these are not embedded, but choose fonts installed on the
user’s computer which are close in style to these font faces.

KEEP THE QUALITY
If you want to keep quality and aren’t worried about file size, you
can set the JPEG compression to 100%, and choose Lossless
compression from the Properties menu for the selected bitmap
image. The properties dialogue box also enables you to switch off
anti-aliasing for the image which will ensure that the clarity of
the image is maintained during playback.

ENHANCE PERFORMANCE
Adding transparency effects to elements in Flash will reduce the
performance of the playback of the final movie. Breaking up large
movies into smaller files makes them faster to load and they can
be handled more efficiently in memory. Performance can also be
enhanced by keeping the first few frames of the Flash movie
simple to ensure that a buffer is built up in the streaming.
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Macromedia Flash
Exchange
www.macromedia.
com/exchange/flash/
Excellent resources
for building better
sites with Flash.

FlashKit
www.flashkit.com/
Source code,
tutorials, help
forums and media.

Flash tutorials for
Interactivity and
Applications
http://graphicssoft.a
bout.com/cs/flashtut
sinteract/
Tutorials and
resources.

Flash 5 Bible
Robert Reinhardt 
List Price: £34.99
Hungry Minds Inc;
ISBN: 0-76453-515-3

Advanced Flash 5
ActionScript in
Action
Dan Livingston 
Price: £27.99 
Prentice Hall PTR;
ISBN: 0-13093-127-6

On the CD:
■ Tutorial files and a
copy of Flash

GOING
FURTHER

STEP THREE: Creating a loader for the game

1As the graphics used in the game take up a

reasonable amount of space, you need a progress

loader to show people that the game is loading.

Create a new scene and in the Scene palette, label

this as “Loader”. Drag and drop the scene so that it’s first

in the list.

2 Create a small animation which can loop over a

series of perhaps four frames. As this is the loader

for the game it is essential that it is very small, so don’t

use graphics which are too flashy, as this defeats the

object of a loader.

3Go back to the first frame and select it. Bring up the

Actions palette and select the “ifFrameLoaded” from

the basic actions palette.We want the Intro page and the

first in-game scene (which we called “scene 1’) to load, so

set the values in the expressions editor.

4 Then if the frame has loaded you want the loader to

stop and move you onto the next scene, so use

“gotoAndStop” to get the loader to move to the next

scene and to the first frame – or you can specify the

name of the scene you want it to move to.

5As the animation in the loader is to be played in a

loop the last frame of the animation needs another

ActionScript inserted to tell the animation to repeat back

to frame 1. For this, use the Basic Actions command

“gotoAndPlay”, choosing the current scene and first frame

number of the scene.

6 The game and the loader are finished and you are

now ready to export the game. Check the scenes

individually and the syntax of the ActionScripts. Delete

unused resources from the Library and use Test Movie

function from the Control menu to check the game

works properly.

7 From the File menu now select Publish settings.

You’ll need to ensure both Flash and HTML are the

chosen formats. In the HTML setting ensure that the

dimensions are set to match the movie and ensure that

the Playback is not paused at the start. Set the scale to

Exact fit as this will hide anything that shouldn’t be seen.

8 Stay within the Publish setting, but now select the

Flash settings. If you have used bitmap graphics, the

lower the JPEG settings the smaller the eventual file size,

so experiment a little to get the smallest acceptable file

size without losing too much image quality.

9 You can prevent the import of your Flash game and

tweak other settings such as audio. Press the Publish

button and test your game in Netscape and Internet

Explorer.You can now amend the HTML page produced

to fit in with your website design and can upload the

game and page to your site for the world to see. MF

➔
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